httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Shahaf <danie...@elego.de>
Subject [PATCH] s/#if/#ifdef/ for AP_ENABLE_DTRACE
Date Tue, 21 Feb 2012 09:21:34 GMT
This patch should suppress the ~only warning I get when building svn
against httpd-2.4.1:

[[[
Index: include/ap_config.h
===================================================================
--- include/ap_config.h (revision 1291669)
+++ include/ap_config.h (working copy)
@@ -194,7 +194,7 @@
 #define AP_NONBLOCK_WHEN_MULTI_LISTEN 1
 #endif
 
-#if AP_ENABLE_DTRACE && HAVE_SYS_SDT_H
+#if defined(AP_ENABLE_DTRACE) && HAVE_SYS_SDT_H
 #include <sys/sdt.h>
 #else
 #undef _DTRACE_VERSION
]]]

For refernce:
[[[
% grep -R AP_ENABLE_DTRACE include/
include/ap_config.h:#if AP_ENABLE_DTRACE && HAVE_SYS_SDT_H
include/ap_config_auto.h.in:#undef AP_ENABLE_DTRACE
include/ap_config_auto.h:/* #undef AP_ENABLE_DTRACE */
]]]

OK to commit?

Mime
View raw message