httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Graham Leggett <minf...@sharp.fm>
Subject Re: httpd-2.3.16-beta "make install" fails...
Date Tue, 07 Feb 2012 14:47:28 GMT
On 07 Feb 2012, at 4:03 PM, Michael Felt wrote:

> Unfortunately, while installing coreutils fixed it for 2.3.16/2.4.0, it is still 'broken'
for 2.2.22
> 
> I have used both the AIXToolBox version - (ancient  coreutils-5.2.1-2) - which has extra
warnings ;) and also
> coreutils 8.14.
> 
> So, new bug-report?

> cc: 1501-228 input file /opt/httpd/lib/libexpat.a not found
> cc: 1501-228 input file /opt/httpd/lib/libapr-1.so not found

Again, it looks like you're trying to build the version of httpd that contains built in copies
of dependent packages, in this case APR, and expat.

You need to package all dependencies of httpd, that means everything in the srclib directory,
as separate system installed packages in order for this to work properly.

Even if you manage to get this to build, you're going to have pain at runtime caused by the
same or similar libraries being installed in the library path potentially multiple times.

Regards,
Graham
--


Mime
View raw message