httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "William A. Rowe Jr." <wr...@rowe-clan.net>
Subject Re: svn commit: r1235968 - /httpd/site/trunk/tools/release.sh
Date Wed, 25 Jan 2012 22:48:27 GMT
On 1/25/2012 4:01 PM, Jim Jagielski wrote:
> Hold on... we're now gonna be shipping apu 1.4 w/ 2.2?
> Where was that decided? If we complain about using
> updated libtools/etc when building these, due to some
> perceived end-user risk, then certainly this introduces
> some "inconsistency" so late in the game for 2.2 users,
> doesn't it?

It is.  It's horribly inconsistent.

But APR offers a rock solid backwards compatibility assurance,
unlike httpd, or autotools, or many other projects.  At least,
withing a given APR major.x.x cycle.

But shipping APU 1.3.x means that current httpd 2.4 packages would
be broken with an httpd 2.2 install.  Not cool.

E.g.

  apr-1.4/configure --prefix=/usr/local/; make; make install
  httpd-2.4/configure --prefix=/opt/test/newhttpd/; make; make install
  httpd-2.2/configure --prefix=/usr/local/; make; make install

Bad mojo.

I'll be certain to include this issue as a second item in the vote.



Mime
View raw message