httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rainer Jung <rainer.j...@kippdata.de>
Subject Re: Win 2.3.16 :: Server Status Entries
Date Wed, 04 Jan 2012 10:37:09 GMT
On 04.01.2012 11:02, Mario Brandt wrote:
> I figured out that using EnableMMAP off causes the L status. I tried
> it in combination with EnableSendfile off and without.

By "without" you mean "EnableSendfile On" or just default? Note that the 
default for EnableSendfile is again "Off" in 2.4, so it is expected we 
don't see a difference between Off and default.

> I hope that helps finding the error.

Thanks,

Rainer

> On Sat, Dec 31, 2011 at 21:08, Steffen<info@apachelounge.com>  wrote:
>>> That's not expected. Can any Windows Seniors comment on that? Why could we
>>> have the Logging status in server-status for a long time for the winnt
>>> MPM?
>>
>>
>> This bug is still there in 2.3.16, have "L" entries for more then a week !
>> They are occupying  workers all the time, so the busyorkers are far high:
>>
>> L__L_L___L____L_L______L___L_L_L__
>>
>>
>> Happy (2.4) new year to all,
>> Steffen
>>
>> -----Original Message----- From: Rainer Jung
>> Sent: Tuesday, December 06, 2011 9:33 PM Newsgroups: gmane.comp.apache.devel
>> To: dev@httpd.apache.org
>> Subject: Re: Win 2.3.15 :: Server Status Entries
>>
>> On 06.12.2011 11:56, Steffen wrote:
>>>>
>>>> Those requests are no longer processed (status is "_"). The seconds
>>>> since is the time since this request was last processed, the column
>>>> after that shows how long processing took (here: "1" millisecond for
>>>> each of them).
>>>
>>>
>>> There are also with status L, for example for almost a day sitting there:
>>>
>>> 0-0 2852 1/2920/2920 L 79507 49835 2893.9 114.05 114.05 80.91.181.75
>>> www.apachelounge.com GET
>>> /download/binaries/httpd-2.2.21-win32-x86-ssl.zip HTTP/1.0
>>
>>
>> That's not expected. Can any Windows Seniors comment on that? Why could
>> we have the Logging status in server-status for a long time for the
>> winnt MPM?
>>
>>> -----Original Message----- From: Rainer Jung
>>> Sent: Tuesday, November 22, 2011 11:32 AM
>>> To: dev@httpd.apache.org
>>> Subject: Re: Win 2.3.15 :: Server Status Entries
>>>
>>> On 22.11.2011 10:28, Steffen wrote:
>>>>
>>>> Seeing a huge number of hanging entries in the Server Status,
>>>> already for 20 hours and looks they are staying there forever.
>>>>
>>>> The requests are invalid, not sure since I do not keep the raw logs.
>>>>
>>>> ...
>>>> ...
>>>> 0-0 3800 0/177/177 _ 64980 1 0.0 0.09 0.09 94.76.244.212
>>>> www.familieland.com GET //phpMyAdmin/scripts/setup.php HTTP/1.1
>>>> 0-0 3800 0/157/157 _ 69024 1 0.0 10.65 10.65 94.76.244.212
>>>> www.familieland.com GET //scripts/setup.php HTTP/1.1
>>>> 0-0 3800 0/224/224 _ 69023 1 0.0 21.96 21.96 94.76.244.212
>>>> www.familieland.com GET //admin/pma/scripts/setup.php HTTP/1.1
>>>> ....
>>>> ....
>>>> etc. etc.
>>>>
>>>> SS = 70878 seconds now and counting.
>>>
>>>
>>> Those requests are no longer processed (status is "_"). The seconds
>>> since is the time since this request was last processed, the column
>>> after that shows how long processing took (here: "1" millisecond for
>>> each of them).
>>>
>>> It looks like you have spare slots that are occasionally used during
>>> load spikes but are idle later for a long time. Don't know how the
>>> Windows MPM decides which idle slot to use.
>>>
>>> Regards,
>>>
>>> Rainer
>>
>>
>

Mime
View raw message