httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Fritsch ...@sfritsch.de>
Subject Re: 2.4.0 GA This week?
Date Tue, 03 Jan 2012 21:19:39 GMT
On Tuesday 03 January 2012, William A. Rowe Jr. wrote:
> On 1/3/2012 3:30 AM, Steffen wrote:
> > Still, I want to ask to reconsider going back to the 2.2 behavior
> > (for the time being).
> 
> Highly unlikely for the reasons I responded nearly a year or so
> back. This bug is irritating, but it is exactly that, a bug.  Not
> 1000's of lines of redundant code.
> 
> Spent last week investigating this and several other obstacles, but
> I don't have an affirmative response yet.  Gregg's recent post will
> likely help me a bunch.

I am glad that there has been some activity on this in the background, 
thanks.

> Stefan, you could likely help on the logging puzzle.  If you look

s/Stefan/Steffen/

> at http://httpd.apache.org/dev/debugging.html#backtrace-win you
> have some basic steps to trigger a core for a -running- httpd.exe.
>  If you could do this once a collection of 'L' statuses have
> accumulated for the child process, the backtraces of those threads
> would be very helpful.  I would anticipate this bug is relatively
> new, in core, and not the win32 mpm, but could be surprised.

One thing that comes to mind was the changing of the EOR bucket 
cleanup to a pre-cleanup. But that was already > 1 year ago. I have no 
idea how this could lead to a hang, do you think it could have broken 
some assumption in the win32 mpm?

Mime
View raw message