httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ruediger Pluem <>
Subject Re: which apr to use, version numbering confusion
Date Tue, 27 Dec 2011 14:34:04 GMT

Mikhail T. wrote:
> On 27.12.2011 08:24, Ruediger Pluem wrote:
>> Some modules in 2.3 require the apr-util crypto API. These
>> won't work with older apr-util versions.
> Oh, Ok -- so a module may just not be built, if apr(-util) is too old at compile time.
But if it is available, it is
> fully-featured, right? In other words, there are no silent #ifs in the code like:
>     #if APR_UTIL_VERSION < 1.4
>     disable some really cool feature or performance improvement
>     #endif

Not directly, but you need to have apr-util 1.4 available during compile time to get these
modules compiled.



View raw message