httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ruediger Pluem <rpl...@apache.org>
Subject Re: which apr to use, version numbering confusion
Date Tue, 27 Dec 2011 07:12:50 GMT


Michael Felt wrote:
> Hi all,
> 
> I am trying to configure and make httpd 3.16 beta on AIX and I see there is a difference
in the way apr is handled.
> However, I am confused about the versioning numbering?
> 
> ./configure  --with-included-apr ... says apr is version 1.4.5 while if I check the apr
mail list, it seems they are
> testing apr version 1.4.1. Are this different packages? (I vaguely recall some discussion
about this about two years ago
> when the 2.3 branch was initially going into testing.)

I guess you confuse APR and APR-UTIL. The most recent version of APR is 1.4.5, of APR-UTIL
is 1.4.1.
You can still run httpd 2.3 with APR-UTIL 1.3.x, but you will miss some features then.
So best starting point is to use the above versions of APR / APR-UTIL.

Regards

RĂ¼diger


Mime
View raw message