httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Graham Leggett <minf...@sharp.fm>
Subject Re: [users@httpd] 2.3.15-beta: module proxy_balancer requires the not automatically loaded module slotmem_shm
Date Wed, 09 Nov 2011 22:24:20 GMT
On 09 Nov 2011, at 11:53 PM, Stefan Fritsch wrote:

> I talked with Rainer about this and we came to the conclusion, that  
> we simply should keep non-default modules commented out, even if  
> they have been explicitly enabled with --enable-foo. This has also  
> the advantage that it is more likely that the user will only enable  
> what he currently needs, even if he has built some additional  
> modules he may need later.

Definite +1.

I hear from time to time people saying that httpd is "big", but it  
turns out they're just loading a bunch of modules they didn't need  
when they started with a default config. It's particularly important  
for distros, where most/all modules are likely to be compiled in  
anyway, but the default config should remain lean.

Regards,
Graham
--


Mime
View raw message