httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kaspar Brand <httpd-dev.2...@velox.ch>
Subject Re: mod_ssl in trunk with OpenSSL 0.9.7 as a minimum requirement?
Date Thu, 11 Aug 2011 05:12:41 GMT
Hi Gün,

> perhaps we should just break compilation with a check in mod_ssl like:
> #if OPENSSL_VERSION_NUMBER < 0x0090700f
> #error mod_ssl requires at least OpenSSL version 0.9.7f!
> #endif

That's also fine with me, yes. Generally speaking, are there any rules
for handling this sort of version checks in httpd code (and when
aborting with #error is acceptable)?

(Nit: 0x0090700f is actually 0.9.7, 0.9.7f would be 0x0090706f.)

> BTW. I admit that I did only tested compile, not runtime; though if 
> there are issues introduced with your changes they should come up with 
> all platforms, or?

I would expect so, yes - as long as OpenSSL behaves the same on NetWare
as on other platforms.

Kaspar

Mime
View raw message