httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Guenter Knauf <fua...@apache.org>
Subject Re: mod_ssl in trunk with OpenSSL 0.9.7 as a minimum requirement?
Date Wed, 10 Aug 2011 12:15:33 GMT
Hi Kaspar,
Am 10.08.2011 08:54, schrieb Kaspar Brand:
> thanks for testing! I was wondering if there's some way to check for
> OPENSSL_VERSION_NUMBER>= 0x0090700f in the NWGNUmakefile (similar to
> what is done in configure). Just in case someone tries to compile
> against stone-age versions of OpenSSL/NTLS... but perhaps this is a very
> unlikely scenario, so not worth bothering about.
sure, that would be possible with some awk magic, but I really see no 
need for that;
perhaps we should just break compilation with a check in mod_ssl like:
#if OPENSSL_VERSION_NUMBER < 0x0090700f
#error mod_ssl requires at least OpenSSL version 0.9.7f!
#endif

?

BTW. I admit that I did only tested compile, not runtime; though if 
there are issues introduced with your changes they should come up with 
all platforms, or?

Gün.



Mime
View raw message