httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gregg L. Smith" <>
Subject Re: Re: [VOTE] Release Apache httpd-2.3.13 as beta
Date Fri, 01 Jul 2011 04:08:34 GMT
Hi Bill, Steffen,

All I can add to this at the moment is this is happening in XP, I am running in Vista x86
just fine.  I have not built on 2008 R2 x64 yet but I will assume (ouch) for now it will work
fine there as well.

I'll try to see if I cannot track this down a little closer to the source, no promises though

So I suppose I am a non-binding -1 since there is a problem ... pre-Vista. The child is crashing
over and over while the parent survives. It's actually quite a struggle to remove all the
crash dialogs from the screen they come so many so fast.

I have not gotten Dr. Watson to give me a backtrace, that may require a different computer,
maybe not, we'll see. I can always try to log before every call to this APR function if worse
comes to worse.


-----Original Message-----
From: "William A. Rowe Jr." <>
Date: Thu, 30 Jun 2011 15:38:38 -0500
Subject: Re: [VOTE] Release Apache httpd-2.3.13 as beta

On 6/30/2011 3:19 PM, Steffen wrote:
> Found the following  in drwatson when it crashes at start up:
> *----> State Dump for Thread Id 0x1e48 <----*
> eax=7c90da1a ebx=00000000 ecx=00c0ffa8 edx=00c0ffb0 esi=0094c198 edi=6ff43294
> eip=6eed568f esp=00c0ff88 ebp=00c0ffec iopl=0         nv up ei pl nz na pe nc
> cs=001b  ss=0023  ds=0023  es=0023  fs=003b  gs=0000 efl=00000202
> function: libapr-1!apr_os_thread_put

Did it happen to provide a backtrace for that thread?  These are the
registers and faulting function, but need to know the callers of
apr_os_thread_put() to understand why it was called with invalid
arguments and second guess which invocation this was.

View raw message