httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "bswen" <>
Subject RE: Cannot build httpd on Win 7 + VS2010
Date Sun, 17 Apr 2011 08:47:45 GMT
I also tried the method suggested by
that uses "perl -2005" to first make VS2005 project files, but all
*.vcproj files cannot converted to VS2010. Does anybody know the reason?
(VS2008 had no problem, though.)


-----Original Message-----
From: Gabriel Petrovay [] 
Sent: Wednesday, October 27, 2010 4:56 AM
Subject: Re: Cannot build httpd on Win 7 + VS2010

I am still experimenting.

I don't think it's a permission problem. I am on a separate partition
with all the necessary rights.

I managed though to build it with nmake only with the "click one more
time" approach. So, by running nmake (NMAKE /f installd)
several times I managed to get over the 'tempfile.bat' errors. Does
this ring a bell?

In VS, they are errors. Trying to built according to:
-> during the first build, I got "header not found" errors complaining
about "apr.h"
-> (I tried one more time) starting from the 2nd build onwards, the
errors are LINK errors. "cannot find external symbol"

With the nmake build above i could finally build/debug the problem
mentioned in the other post (slow shutdown waiting for treads) (I see
that you already replied to that, and I am curious ;) )


On Tue, Oct 26, 2010 at 10:41 PM, Gregg L. Smith <> wrote:
> Hello Gabriel,
> I've run into this on xp, vista & 2008. Somehow source folders get put in
read only mode. Make them writable again and it will build. On Win7 if that
means putting it in Documents, so be it.
> As far as errors in IDE, you sure they are not warnings? 2 warnings per
project is what I see on 2010. I do not like 2010 so I haven't compiled
Apache with since I gave it a try after it's release.
> Gregg
> Original Message -----------------------
> Hi,
> Can you make Apache build on Windonws 7 and Visual Studio 2010?
> Neither the nmake nor the IDE builds work:
> nmake -f installd
> Error:
> aprutil.mak(1459) : fatal error U1054: cannot create inline file
> IDE:
> building project InstallBin
> => thousands of errors
> Are these build scripts/project maintained?
> Thanks!
> --
> MSc Gabriel Petrovay
> Mobile: +41(0)787978034

MSc Gabriel Petrovay
Mobile: +41(0)787978034

View raw message