httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "William A. Rowe Jr." <wr...@rowe-clan.net>
Subject If there is a win32 2.4 build...
Date Mon, 21 Mar 2011 01:12:16 GMT
It seems overdue to bump to expat 2.0.1.

The attached seems to be the delta we (win and netware) likely care about
to resolve significant defects in 2.0.1 (straight from their cvs tree,
ignoring highly unusual platforms, and gratuitous whitespace changes).

My inclination is to build for 2.4 using the 'stock' expat .dll of this
plus 2.0.1 base distribution, irrespective of the sources shipped in
srclib/apr-util/xml/expat since 1.95 is far from current.  This is likely
to make interop easier for anyone working with modern perl/python/php/etc.
I would also jump up to openssl 1.0.0x (current), zlib 1.2.5 (although
I detest its 64 bit off_t handling, which is a seperate discussion already
started on another list) and drop apr_iconv altogether, which means also
dropping the compilation of mod_charset_lite - I believe no other modules
would be affected by this change.

Comments?


Mime
View raw message