httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Fritsch>
Subject Re: remove "experimental" label from mod_allowmethods?
Date Mon, 07 Mar 2011 21:25:25 GMT
On Monday 07 March 2011, William A. Rowe Jr. wrote:
> Problem: It doesn't follow the naming conventions of an aaa module.
> I don't remember if it's been renamed a few times already, but if
> it behaves as authn/authz it should be named into that schema.

It behaves somewhat different in that it does not use mod_authz_core 
and is unaffected by mod_authz_core's inheritance/merging (which is 
intentional and wanted). Also, the authz provider for 'Require method' 
is already contained in mod_authz_core. Therefore renaming 
mod_allowmethods to mod_authz_method would be a bit confusing, IMHO.

I am fine with the current name, but if you have a better suggestion, 
that's fine too.

View raw message