httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gregg L. Smith" <...@gknw.net>
Subject Re: Re: HEAD on trunk broken
Date Wed, 16 Mar 2011 00:27:13 GMT
Thanks R??diger, Jim,

This fixes the crash on Window's I had reported couple week ago. Ping Nick.

Regards,
Gregg

-----Original Message-----
From: Jim Jagielski <jim@jaguNET.com>
To: dev@httpd.apache.org
Date: Thu, 10 Mar 2011 11:51:14 -0500
Subject: Re: HEAD on trunk broken


On Mar 10, 2011, at 11:43 AM, Pl??m, R??diger, VF-Group wrote:
>> 
>> I guess the following patch should fix that:
>> 
>> Index: mod_authn_socache.c
>> ===================================================================
>> --- mod_authn_socache.c (revision 1080266)
>> +++ mod_authn_socache.c (working copy)
>> @@ -126,11 +126,12 @@
>> }
>> static void authn_cache_child_init(apr_pool_t *p, server_rec *s)
>> {
>> -    const char *lock = apr_global_mutex_lockfile(authn_cache_mutex);
>> +    const char *lock;
>>     apr_status_t rv;
>>     if (!configured) {
>>         return;       /* don't waste the overhead of 
>> creating mutex & cache */
>>     }
>> +    lock = apr_global_mutex_lockfile(authn_cache_mutex);
>>     rv = apr_global_mutex_child_init(&authn_cache_mutex, lock, p);
>>     if (rv != APR_SUCCESS) {
>>         ap_log_error(APLOG_MARK, APLOG_CRIT, rv, s,
>> 
> 
> Feel free to commit if it resolves the issue as I won't have a chance to do
> so today or tomorrow morning.
> 

It does... no idea yet why this started happening though,
unless it's due to some changes w/ default modules??





Mime
View raw message