httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Zeno Davatz <zdav...@gmail.com>
Subject Re: MinGW and Apache
Date Mon, 07 Feb 2011 10:15:11 GMT
Dear Günter

Thank you for your reply.

On Mon, Feb 7, 2011 at 11:01 AM, Guenter Knauf <fuankg@apache.org> wrote:

>> On Sat, Feb 5, 2011 at 12:15 AM, Guenter Knauf<fuankg@apache.org>  wrote:
>>>
>>> Am 04.02.2011 23:58, schrieb Zeno Davatz:
>>> did you 1st check that your MinGW Apache runs fine without mod_ruby?
>>
>> That is the point I do not yet fully understand. At the moment I am
>> using the default Apache for Windows Version 2.2.17 compiled with
>> Microsoft Visual Studio (normal msi-Installer). But my Ruby and
>> mod_ruby for Windows where both compiled using MinGW-gcc-3.4.5.
>
> this is where I misunderstood you: I thought that you were also tying to get
> httpd / APR / APU compiled with MinGW, and not only mod_ruby.
>
>> I tried that. Does not make a difference. I tried both MinGW-gcc-4.5
>> and MinGW-gcc3.4.5
>
> Here I meant to compile httpd / APR / APU with MSYS/MinGW. I believe that
> now with latest MSYS chances increased that a normal configure build works;
> just a few days back I had to compile binutils for Win32, and while this was
> a pain some years back when I last looked at it now it worked great (though
> this might not only be because of MSYS improvements, but also binutils
> changes).
>
>>>> If you point me towards the people I will try to get in touch to push
>>>> this a bit forward. I am also willing to back it up financially to a
>>>> certain extent.
>>>
>>> I'm interested into it, and you may contact me.
>
> Again, here I meant to get httpd / APR / APU compiled with MinGW.

Can you point me to your steps where you done so?

>> Can you try to follow my steps I listed here and tell me if the Module
>> loads for you at startup?. Actually you can download the mod_ruby.so
>> compiled with MinGW from below link:
>>
>> http://dev.ywesee.com/wiki.php/Apache/Libapr-1
>
> thats not possible since the DLLs you linked against are missing in the
> archive.

Ok, I updated the Makefile. With this Makefile the compilation worked
with MinGW.

https://gist.github.com/814202

I also copied the DLLs according to .a filenames. So my bin directory
now has theses DLLs as well:

libapr-1c.dll
libapr-1s.dll

libhttpd-c.dll
libhttpd-s.dll

libaprutil-1.dll
libaprutil-1c.dll

That made the errors in Dependency-Walker go away.

I am also able to start httpd with mod_ruby.so from the commandline
but not via the GUI. That seems very strange.

Best
Zeno

Mime
View raw message