httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Zeno Davatz <zdav...@gmail.com>
Subject Re: MinGW and Apache
Date Sat, 05 Feb 2011 09:09:15 GMT
Dear G√ľnter

On Sat, Feb 5, 2011 at 12:15 AM, Guenter Knauf <fuankg@apache.org> wrote:
> Am 04.02.2011 23:58, schrieb Zeno Davatz:
>>
>> I gave it a try (it took some time ;): These are the steps I took to
>> compile mod_ruby.so with MinGW-gcc.3.4.5 against Apache 2.2.17 on
>> Windows.
>>
>> http://dev.ywesee.com/wiki.php/Apache/Libapr-1
>>
>> The module finally compiles fine _but_ Apache does not start. Apaches
>> tells me that the Module can not be found. But the module is there and
>> it compiled fine. So something seems strange.
>>
>> I am grateful for any hints.
>
> did you 1st check that your MinGW Apache runs fine without mod_ruby?

That is the point I do not yet fully understand. At the moment I am
using the default Apache for Windows Version 2.2.17 compiled with
Microsoft Visual Studio (normal msi-Installer). But my Ruby and
mod_ruby for Windows where both compiled using MinGW-gcc-3.4.5.

>> Both Ruby and mod_ruby where compiled with MinGW-gcc-3.4.5.
>
> I would recommend that you get latest MSYS/MinGW which has gcc 4.5 now.

I tried that. Does not make a difference. I tried both MinGW-gcc-4.5
and MinGW-gcc3.4.5

>> If you point me towards the people I will try to get in touch to push
>> this a bit forward. I am also willing to back it up financially to a
>> certain extent.
>
> I'm interested into it, and you may contact me.

Can you try to follow my steps I listed here and tell me if the Module
loads for you at startup?. Actually you can download the mod_ruby.so
compiled with MinGW from below link:

http://dev.ywesee.com/wiki.php/Apache/Libapr-1

Best
Zeno

Mime
View raw message