httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jim Jagielski <...@jaguNET.com>
Subject 2.4 and APR_HAS_THREADS, etc
Date Fri, 07 Jan 2011 16:01:07 GMT
There's a lot of cruft in 2.3/2.4 that, imo at least, doesn't
belong in a 2011-era codebase. For example, 2.3/2.4 should
*require* support for threads, and shared-memory and other
such stuff that we test for and work around.

This is stupid. Even with prefork, we should require that
APR was built with thread support. In other words, if
APR wasn't built with threads (and shared mem, etc),
then httpd shouldn't run in any case.

I propose that this low-hanging fruit be picked...


Mime
View raw message