httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Fritsch ...@sfritsch.de>
Subject Re: speaking of naming conventions
Date Wed, 01 Dec 2010 19:40:24 GMT
On Wednesday 01 December 2010, William A. Rowe Jr. wrote:
> Did anyone else wonder about ap_expr_eval_ctx and ap_expr and
> wonder why there is a missing _t?  I certainly don't read ap_expr
> and think "oh yea, that would be a type".

I guess I took ap_expr because it was called ssl_expr originally. I 
have no problem with renaming, but we should collect everything that
needs renaming and do it in one go.

So we add _t to these:

ap_expr
ap_expr_eval_ctx
ap_expr_parse_ctx

What about these? Add a _t, too?

ap_expr_lookup_parms
ap_expr_lookup_fn

Or should it be apr_expr_lookup_func (we have ap_in_filter_func, 
etc.).

And should the enum ap_expr_node_op be ap_expr_node_op_e?

Mime
View raw message