httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "William A. Rowe Jr." <wr...@rowe-clan.net>
Subject Re: Head's up - T&R of 2.3.9-alpha real soon and push for GA
Date Mon, 29 Nov 2010 19:04:03 GMT
On 11/23/2010 8:22 AM, Jim Jagielski wrote:
> 
> On Nov 22, 2010, at 6:30 PM, Guenter Knauf wrote:
> 
>> How about this one?
>> ./modules/session/mod_sesion_crypto.c:
>>
>> #if APU_MAJOR_VERSION == 1 && APU_MINOR_VERSION < 4
>>
>> #error session_crypto_module requires APR v1.4.0 or later
>>
>> ...
>>
>> seems we cant compile this one unless we release APU 1.4.x, or?
>> and for now the -dep still contains an APU 1.3.x .... :-)
>> BTW. we also have not yet updated expat stuff in APU 1.4.x branch ...
> 
> I don't see this as a regression for alpha...

It absolutely isn't.  I'm entirely not satisfied that reviewers have spent
any amount of time with this major new feature in apr-util 1.4, still.  That
release, when APR decides to do it, introduces a newly locked-in interface
that has to be correct from day one.  Ideally, it proves correct enough to
live on as-is into APR 2.0.

An autoconf test is a trivial way to disable this module.

But this is no change from httpd 2.3.8-alpha, so we'll keep moving on :)

Mime
View raw message