httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Fritsch ...@sfritsch.de>
Subject Re: Better name for mod_authz_host?
Date Fri, 24 Sep 2010 15:51:47 GMT
On Friday 24 September 2010, Eric Covener wrote:
> 2010/9/24 Igor Galić <i.galic@brainsware.org>:
> > ----- "Rainer Jung" <rainer.jung@kippdata.de> wrote:
> >> Is there a better name for mod_authz_host in 2.4?
> >> 
> >> It currently does "Require X" with "X" in
> >> 
> >> - ip
> >> - host
> >> - env
> >> - all
> >> - method
> >> 
> >> I'd say the module name gets confusing now, since it implements
> >> most of
> >> the "easy" authz checks. Something like mod_authz_simple,
> >> mod_authz_request, mod_authz_kitchensink, ...?
> > 
> > In no particular order:
> > 
> > mod_authz_simple
> > mod_authz_general
> > mod_authz_default

Renaming always creates additional work on upgrades.

> We could also shove them in authz_core

+1 for all, env, and method

I am indifferent about ip and host. But probably every user has at 
least an "allow from localhost" in his config, so there does not seem 
to be much advantage in having them in a separate module.

Mime
View raw message