httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Abhinav Upadhyay <abhi...@hover.in>
Subject Re: undefined symbol errors on loading a module that uses libxml2
Date Mon, 21 Jun 2010 14:16:53 GMT



alin vasile <alinachegalati <at> yahoo.com> writes:

> 
> 
> 
> execute a ldd for /usr/lib/libxml2.so and see if all the dependecies are
satisfied.
>  
> Post the entire LoadModule/LoadFile area, I'm not sure if the order matters.
> 
> 
> 
> From: Abhinav Upadhyay <abhinav <at> hover.in>To: dev <at>
httpd.apache.orgSent: Sun, June 20, 2010 7:56:23 PMSubject: undefined symbol
errors on loading a module that uses libxml2Hello everyone! I am writing an
Apache 2.2 module that uses the libxml2 API. I have compiled themodule using
following commands:apxs -I /usr/include/libxml2/ -c mod_xmltest.csudo apxs -n
xmltest_module -i mod_xmltest.laand used the following LoadFile directive in
httpd.confLoadFile /usr/lib/libxml2.soHowever on s
>  tarting the server I am getting following error:httpd: Syntax error on line
432 of /usr/local/apache2/conf/httpd.conf: Cannotload
>  /usr/local/apache2/modules/mod_hoverin.so into
server:/usr/local/apache2/modules/mod_hoverin.so: undefined symbol:
xmlFreeNodewhat could be wrong here ?Thanks and RegardsAbhinav
> 
> 
> 
> 
> 
Hi, thanks for replying.
I tried changing the order of the directives.
I put the LoadFile directive before the LoadModule directive and it worked.
Thanks and Regards
Abhinav




Mime
View raw message