httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dan Poirier <poir...@pobox.com>
Subject Re: Reducing number of mod_lua hook directives
Date Tue, 11 May 2010 12:52:06 GMT
On 2010-05-10 at 16:03, "William A. Rowe Jr." <wrowe@rowe-clan.net> wrote:
> On 5/10/2010 2:25 PM, Brian McCallister wrote:
>>> ...
>>>
>>> to
>>>
>>> LuaHook AccessChecker /path/to/script.lua  funcname
>>> LuaHook AuthChecker   /path/to/script.lua  funcname
>>> LuaHook CheckUserID   /path/to/script.lua  funcname
>
> Any reason not to name the func before the script, especially since path names
> can get long winded, and I'm thinking C like decl funcname(args) {script}

So we'd have

LuaHook AccessChecker funcname /path/to/script.lua

and (unchanged)

<LuaHook AccessChecker funcname>

which makes the two forms more consistent too.  Sounds fine to me.

Dan

Mime
View raw message