httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sander Temme <scte...@apache.org>
Subject Re: [PATCH] Support compiling httpd against APR/apr-util 1.x when buildconf against 2.x/trunk
Date Sun, 30 May 2010 02:39:26 GMT

On May 29, 2010, at 6:36 PM, Justin Erenkrantz wrote:

> I would like to go commit the following to apr and httpd trunk.
> 
> I don't think it is appropriate for the local buildconf-time
> environment to make it impossible at configure-time to use an older
> APR configuration.  Restoring find_apu.m4 to apr trunk resolves this
> issue for me.  (I'm leaving the ifdef in httpd configure.in to not
> force everyone to update their APR/httpd trunks in unison; but I can
> be convinced to remove the ifdef...)

Wouldn't we rather move to a construct where APR is not needed to buildconf?  If all we're
doing is copy in find_apr.m4, can't we just fork that and allow it to evolve into our own
idea of finding an appropriate APR against which to configure? 

That would render the issue of buildconf against 2.x/trunk vs. configure against 1.x moot.

S.

> Thoughts?  -- justin
> 
> (for APR)
> svn cp https://svn.apache.org/repos/asf/apr/apr-util/branches/1.5.x/build/find_apu.m4
> https://svn.apache.org/repos/asf/apr/apr/trunk/build/find_apu.m4
> 
> (for httpd)
> Index: configure.in
> ===================================================================
> --- configure.in	(revision 949455)
> +++ configure.in	(working copy)
> @@ -120,8 +120,6 @@
> elif test "x$with_included_apr" = "xyes"; then
>    apu_found=reconfig
> else
> -   dnl If httpd is buildconf'ed against an apr 2.x tree, then 1.x
> -   dnl isn't supported.
>    ifdef([APR_FIND_APU], [
>      APR_FIND_APU("$srcdir/srclib/apr-util", "./srclib/apr-util",
>                   1, ${apr_major_version})
> Index: buildconf
> ===================================================================
> --- buildconf	(revision 949455)
> +++ buildconf	(working copy)
> @@ -170,6 +170,8 @@
>    $apr_src_dir/build/find_apr.m4 build
> if [ $apr_major_version -lt 2 ] ; then
>     cp $apu_src_dir/build/find_apu.m4 build
> +else
> +    cp $apr_src_dir/build/find_apu.m4 build
> fi
> 
> # Remove any libtool files so one can switch between libtool 1.3
> 
> 



-- 
Sander Temme
sctemme@apache.org
PGP FP: 51B4 8727 466A 0BC3 69F4  B7B8 B2BE BC40 1529 24AF




Mime
View raw message