httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Rack <m...@michaelrack.de>
Subject Re: Problems with fcgid 2.3.5 + Apache 2.2.15 + suEXEC
Date Wed, 05 May 2010 18:55:46 GMT
Now i've configured PHP as FastCGI Application. And it works as well.

But if you take your SVN-TAG 2.3.5 that is currently marked as stable 
and is available for download via your local mirrors, there is no change 
to get FCGID running with SuexexUserGroup enabled.

You should make a new tag so fast as possible to geht rid of this issue.

Download-Page wich is problematic:
http://httpd.apache.org/download.cgi#mod_fcgid

How to reproduce the Problem:
Do the same steps as 
http://httpd.apache.org/mod_fcgid/mod/mod_fcgid.html to setup a 
FastCGI-Environment.
Now test your setup. Everything will work fine. Now enable Suexec with 
SuexecUserGroup [user] [group]. Remember to change the permissions for 
your wrapper-script. Now try to access your script again, you will get 
an 500 Error! And now the best: You don't get rid about this problem, 
because error_log does not show up anything.

-- 
Liebe Grüße aus Freilassing,

Michael Rack


Am 04.05.2010 15:29, schrieb Jeff Trawick:
> On Tue, May 4, 2010 at 3:08 AM, Michael Rack<mail@michaelrack.de>  wrote:
>    
>> Dear Jeff,
>>
>> the CGI-Script does not contain any FastCGI spezific changes. The same file
>> is used for CGI and FastCGI.
>>
>> I will give it a try with FastCGI spezific code-lines.
>>
>> ---snipp--
>> #!/bin/sh
>> echo "Content-Type: text/plain"
>> echo ""
>> /usr/bin/date
>> ---snapp--
>>
>> That is the CGI-Script. In apache/logs/error_log i can see this Output. But
>> this is first since i've installed the SVN-Trunk version.
>>      
> If the output of the application prior to handling FastCGI connections
> goes to the main server error log, that's good (at least, that's what
> the code has tried to do for some years now).  I don't know why this
> started happening for you with recent mod_fcgid code changes.  (Or
> maybe I misunderstood you about this being new behavior.)
>
> I don't think any version of mod_fcgid has supported a non-FastCGI
> application like yours by running it in normal CGI mode.
>
>    
>> Rests upon any of the changes between Rev 901800 (tags/2.3.5) and Rev 939478
>> (trunk) on mod_fcgid + suEXEC ? If so, when does a new release been tagged
>> with this changes, to solve this probleme for a wide range of users?
>>      
> shrug
>
>    
>> Liebe Grüße aus Freilassing,
>>
>> Michael Rack
>>
>>
>> Am 03.05.2010 22:09, schrieb Jeff Trawick:
>>      
>>> On Mon, May 3, 2010 at 3:51 PM, Michael Rack<mail@michaelrack.de>    wrote:
>>>
>>>        
>>>> Strange UPDATE (Please take a seat) ;-)
>>>>
>>>> I have checkouted the SVN Trunk of mod_fcgid, compiled and installed.
>>>>
>>>> Now there is a very strange behavior.
>>>>
>>>> I still get the 500 Internal Sever Error, but suexec shows up the line
>>>> that
>>>> the cgi was called and run with UID 2000/system.
>>>>
>>>> /usr/apache/logs/error_log drive crazy! I can see the output of my
>>>> CGI-File
>>>> there!
>>>>
>>>>          
>>> When the FastCGI app starts up *initially*, stdout and stderr are the
>>> main server error log.  The FastCGI programming library used by the
>>> app will presumably reroute stdout and stderr to the FastCGI pipe
>>> while processing a client connection.
>>>
>>> Are you seeing error messages or a normal HTTP response?
>>>
>>>
>>>        
>>>> The errorlog /opt/vhosts/admin.rsm-freilassing.de/logs/error_log contains
>>>> the same lines as before "(104) Connection reset by peer: mod_fcgid:
>>>> error
>>>> reading data from FastCGI server".
>>>>
>>>> What the hell is going on?
>>>>
>>>>          
>>> The script doesn't realize its running in FastCGI mode, never responds
>>> on the FastCGI pipe?
>>>
>>> What is this script?  Has it been coded to handle both CGI and FastCGI?
>>>        

Mime
View raw message