httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kevac Marko <ma...@kevac.org>
Subject Re: Building httpd trunk. Problem with apr-util.
Date Sun, 14 Mar 2010 10:22:46 GMT
Built httpd-trunk with apr-trunk and apr-util-trunk.

But still, some questions remained:

1) Where information about what version of apr and apr-util is needed
for each verson of httpd could be found?
2) Where is --with-apr-util or --with-apu configuration option?

On Sun, Mar 14, 2010 at 11:46 AM, Kevac Marko <marko@kevac.org> wrote:
> Hello.
>
> After cloning httpd git repository (mirror of svn one), I have tried
> to build trunk, but I don't know hot to tell build sripts what
> apr-util library to use.
>
> ----------------------------------------------------------------------------
> $ ./configure --with-apr=/usr/bin/apr-1-config
> --with-apr-util=/usr/bin/apu-1-config
> --prefix=/home/marko/micex/opt/httpd/trunk/ 2>&1 | tee configure.log
> checking for chosen layout... Apache
> checking for working mkdir -p... yes
> checking build system type... x86_64-unknown-linux-gnu
> checking host system type... x86_64-unknown-linux-gnu
> checking target system type... x86_64-unknown-linux-gnu
>
> Configuring Apache Portable Runtime library ...
>
> checking for APR... yes
>  setting CC to "x86_64-linux-gnu-gcc"
>  setting CPP to "x86_64-linux-gnu-gcc -E"
>  setting CFLAGS to "  -pthread"
>  setting CPPFLAGS to " -DLINUX=2 -D_REENTRANT -D_GNU_SOURCE"
>  setting LDFLAGS to " "
>
> Configuring Apache Portable Runtime Utility library...
>
> configure: error: APR-util not found.  Please read the documentation
> ----------------------------------------------------------------------------
>
> There is no "--with-apr-util" in "./configure --help", so it is just guessing.
>
> ----------------------------------------------------------------------------
> marko@marko-desktop:~/micex/distr/git/httpd$ which apr-1-config
> /usr/bin/apr-1-config
> marko@marko-desktop:~/micex/distr/git/httpd$ which apu-1-config
> /usr/bin/apu-1-config
> ----------------------------------------------------------------------------
>
> By the way, what version of apr and apr-util httpd-trunk requires?
>
> --
> Marko Kevac
>



-- 
Marko Kevac

Mime
View raw message