httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "William A. Rowe Jr." <wr...@rowe-clan.net>
Subject Re: Fighting with build process 2.2.x on Sparc Solaris 10
Date Fri, 05 Mar 2010 22:58:31 GMT
On 3/5/2010 4:41 PM, Thomas, Peter wrote:
> Getting further [in addition to pulling down the obvious additional
> dependency, libnet]:
> 
> 1) check out the last released version of apr and apr-util [v1.3.9]
> 2) configure, build, and install apr
> 3) configure, build, and install apr-util [ran into a subtle problem
> where installing apr-util writes back into the local build directory,
> which was denied because my home directory was root_squashed--rebuilt
> apr-util under /var/tmp/apr-util, installed from there, and then moved
> it back into my srclib tree].
> 4) configure & build httpd
> 
> Now I'm getting an odd-ball error while building httpd...thoughts?
> 
> /bin/cc   -L/usr/local/lib -I/usr/local/include -L/usw/sfw/lib
> -I/usr/sfw/include -xO4 -xchip=generic -I/usr/sfw/include/openssl
> -DSOLARIS2=10 -D_POSIX_PTHREAD_SEMANTICS -D_REENTRANT
> -D_LARGEFILE64_SOURCE  -L/usr/local/lib -I/usr/local/include
> -L/usw/sfw/lib -I/usr/sfw/include -I/usr/sfw/include/openssl
> -I/.../httpd-2.2.x/srclib/pcre -I. -I/.../httpd-2.2.x/os/unix
> -I/.../httpd-2.2.x/server/mpm/prefork -I/.../httpd-2.2.x/modules/http
> -I/.../httpd-2.2.x/modules/filters -I/.../httpd-2.2.x/modules/proxy
> -I/.../httpd-2.2.x/include -I/.../httpd-2.2.x/modules/generators
> -I/.../httpd-2.2.x/modules/mappers -I/.../httpd-2.2.x/modules/database
> -I/usr/local/apr/include/apr-1
> -I/.../httpd-2.2.x/modules/proxy/../generators -I/usr/sfw/include
> -I/.../httpd-2.2.x/modules/ssl -I/.../httpd-2.2.x/modules/dav/main -c
> /.../httpd-2.2.x/server/buildmark.c
> /usr/local/apr/build-1/libtool --silent --mode=link /bin/cc
> -L/usr/local/lib -I/usr/local/include -L/usw/sfw/lib -I/usr/sfw/include
> -xO4 -xchip=generic -I/usr/sfw/include/openssl   -L/usr/sfw/lib   -o
> httpd  modules.lo buildmark.o -export-dynamic server/libmain.la
> modules/aaa/libmod_authn_file.la modules/aaa/libmod_authn_default.la
> modules/aaa/libmod_authz_host.la modules/aaa/libmod_authz_groupfile.la
> modules/aaa/libmod_authz_user.la modules/aaa/libmod_authnz_ldap.la
> modules/aaa/libmod_authz_default.la modules/aaa/libmod_auth_basic.la
> modules/filters/libmod_include.la modules/filters/libmod_filter.la
> modules/loggers/libmod_log_config.la modules/metadata/libmod_env.la
> modules/metadata/libmod_setenvif.la modules/metadata/libmod_version.la
> modules/ssl/libmod_ssl.la modules/http/libmod_http.la
> modules/http/libmod_mime.la modules/generators/libmod_status.la
> modules/generators/libmod_autoindex.la modules/generators/libmod_asis.la
> modules/generators/libmod_cgi.la modules/mappers/libmod_negotiation.la
> modules/mappers/libmod_dir.la modules/mappers/libmod_actions.la
> modules/mappers/libmod_userdir.la modules/mappers/libmod_alias.la
> modules/mappers/libmod_so.la  server/mpm/prefork/libprefork.la
> os/unix/libos.la -lm /.../httpd-2.2.x/srclib/pcre/libpcre.la
> /usr/local/apr/lib/libaprutil-1.la -lexpat -liconv
> /usr/local/apr/lib/libapr-1.la -luuid -lsendfile -lrt -lsocket -lnsl
> -lpthread
> Undefined                       first referenced
>  symbol                             in file
> __divdi3                            server/.libs/libmain.a(util_time.o)
> (symbol belongs to implicit dependency /usr/local/lib/libgcc_s.so.1)

What if -lm is placed after libapr[util]?  Not sure what is going on, but
it looks like you might be building some of this with sun cc and part with
gnu cc (gcc)?


Mime
View raw message