httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Felt <mamf...@gmail.com>
Subject Re: building httpd-2.0.63 on AIX 6.1 - stuck: make install fails after buildconf
Date Sun, 20 Dec 2009 12:51:49 GMT
I have considered that, but until I better understand how configure, make
and libtool are suppossed to work together, I prefer leaving things, as much
as possible, as they are.

Could it be a problem that I have "make installed" apr and apr-util for
httpd-2.2? This is another aspect of the different versions of apache I do
not really understand - specifically - which version(s) of apr are
supported/compatible.

At the moment I am thinking of just copying this file (and perhaps others as
I come to them)  to the location "demanded".

What I consider unfortunate, and again unsure of where the exact problem
lies - or I would try to work out a patch - is that the make install worked
fine before the buildconf - but the wrong file extensions for the modules
(.a rather than .so) are generated, where after buildconf - the correct
files are made, but make install is broken.

On Sun, Dec 20, 2009 at 4:31 AM, Eric Covener <covener@gmail.com> wrote:

> On 12/19/09, Michael Felt <mamfelt@gmail.com> wrote:
> >  cc: 1501-228 input file /usr/local/apache2/lib/libapr-0.so
>
> You need to backtrack to the "make install" of the bundled APR, as
> this is what apr-util is complaining about.    You might find it
> easier to build against an installed, rather than a bundled, APR to
> simplify/separate.
>
> --
> Eric Covener
> covener@gmail.com
>

Mime
View raw message