httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Felt <mamf...@gmail.com>
Subject Re: Building 2.3.4.alpha on AIX 6.1
Date Fri, 18 Dec 2009 15:33:49 GMT
When not running as root, I see directories where I cannot go, but the file
is there...

find: bad status--
/data/prj/alpha/build/httpd-2.3.4/opt/aixt/apache2/modules/mod_authn_file.la
find: cannot chdir to </etc/corrals> : Permission denied
find: cannot chdir to </etc/security> : Permission denied
find: cannot chdir to </etc/tunables> : Permission denied
find: cannot chdir to </usr/lib/boot/network> : Permission denied
find: cannot chdir to </usr/lib/drivers/crypto> : Permission denied
find: cannot open < /usr/lib/corrals >
install: File mod_authn_file.lai was not found.
make: 1254-004 The error code from the last command is 2.


Stop.
make: 1254-004 The error code from the last command is 1.


Stop.
make: 1254-004 The error code from the last command is 1.


Stop.
make: 1254-004 The error code from the last command is 1.


Stop.
*$ ls -ld /etc/cor*
drwx------    3 root     system          256 Nov 16 22:42 /etc/corrals
$ find . -name mod_authn_file.lai
./modules/aaa/.libs/mod_authn_file.lai*
$

On Fri, Dec 18, 2009 at 4:09 PM, Michael Felt <mamfelt@gmail.com> wrote:

> I am not so smart with lists to give you a link. But I provided the extra
> output before --
>
> some snips here though:
>
> In short, as far as I can tell, the file has been made and is sitting inthe
> ..../aaa/.libs directory.
> So I am curious why it is not found.
>
> I had different errors when I almost installed over my regular install
> (fortunately I was not root) and I suspect that there is something "unusual"
> abou where it is looking for the files (not in . or it would find them)
> ======= older post =========
> dev@httpd.apache.org
> dateThu, Dec 10, 2009 at 6:44 PM subjectRe: Building 2.3.4.alpha on AIX
> 6.1 mailed-bygmail.com
> hide details Dec 10 (8 days ago)
>
> Success - well almost. Was this also covered in the VOTE thread?
> ====
> Making install in modules
> Making install in aaa
> rm -f /opt/aixt/apache2/modules/mod_authn_file.so
> /data/prj/alpha/httpd-2.3.4-alpha/srclib/apr/libtool --silent
> --mode=install install mod_authn_file.la /opt/aixt/apache2/modules/
>
> find: bad status-- /opt/aixt/apache2/modules/mod_authn_file.la
> install: File mod_authn_file.lai was not found.
> make: 1254-004 The error code from the last command is 2.
>
>
>
> Stop.
> make: 1254-004 The error code from the last command is 1.
> ====
>
> # find . -name mod_authn_file.\*
> ./docs/manual/mod/mod_authn_file.html
> ./docs/manual/mod/mod_authn_file.html.en
> ./docs/manual/mod/mod_authn_file.html.fr
> ./docs/manual/mod/mod_authn_file.html.ja.utf8
> ./docs/manual/mod/mod_authn_file.html.ko.euc-kr
> ./modules/aaa/mod_authn_file.c
> ./modules/aaa/mod_authn_file.dsp
> ./modules/aaa/mod_authn_file.o
> ./modules/aaa/.libs/mod_authn_file.lai
> ./modules/aaa/.libs/mod_authn_file.la
> ./modules/aaa/mod_authn_file.la
> ./modules/aaa/mod_authn_file.slo
> ./modules/aaa/mod_authn_file.lo
> ====
> So, what did I miss :)
> - Show quoted text -
>
>
> On Wed, Dec 16, 2009 at 10:43 AM, Graham Leggett <minfrin@sharp.fm> wrote:
>
>> Michael Felt wrote:
>>
>> >                 > ====
>> >                 > Making install in modules
>> >                 > Making install in aaa
>> >                 > rm -f /opt/aixt/apache2/modules/mod_authn_file.so
>> >                 > /data/prj/alpha/httpd-2.3.4-alpha/srclib/apr/libtool
>> >                 --silent --mode=install
>> >                 > install mod_authn_file.la <http://mod_authn_file.la>
>> >                 /opt/aixt/apache2/modules/
>> >                 > find: bad status--
>> >                 /opt/aixt/apache2/modules/mod_authn_file.la
>> >                 <http://mod_authn_file.la>
>> >                 > install: File mod_authn_file.lai was not found.
>> >                 > make: 1254-004 The error code from the last command is
>> 2.
>>
>> One observation - this snippet is just a snippet from your build output,
>> and the error is that a file isn't found.
>>
>> I would guess the real error is further up in your build, where I
>> predict an error occurred causing the file that isn't found to not be
>> generated in the first place.
>>
>> Can you also clarify what steps you are using to build, specifically
>> command line options.
>>
>> Regards,
>> Graham
>> --
>>
>
>

Mime
View raw message