httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Felt <mamf...@gmail.com>
Subject Re: [RESULTS] [VOTE] Release httpd 2.3.4-alpha
Date Thu, 10 Dec 2009 12:26:39 GMT
michael@x054:[/data/prj/pcre-8.00]ls bin
ls: 0653-341 The file bin does not exist.
michael@x054:[/data/prj/pcre-8.00]mkdir bin
michael@x054:[/data/prj/pcre-8.00]ls *config
pcre-config
michael@x054:[/data/prj/pcre-8.00]ln *config bin
michael@x054:[/data/prj/pcre-8.00]

* that seems to have solved the ./configure problem, but I suspect the build
will not succeed. -lpcre is not in /usr/local/lib - it is still, at best, in
the directory area of the project source.

What does the --with-pcre=.... actually mean? I would hope it is not just to
find the config program, that is no (longer?) stored in the ./bin/ directory
as expected.

michael@x054:[/data/prj/alpha/httpd-2.3.4-alpha]*grep pcre nohup.out*
checking for pcre-config... false
configure: Using external PCRE library from
/data/prj/pcre-8.00/bin/pcre-config
  setting PCRE_LIBS to "-L/usr/local/lib -lpcre"
michael@x054:[/data/prj/alpha/httpd-2.3.4-alpha]f*ind /usr/local/lib
/data/prj/pcre* | grep libpcre*
/data/prj/pcre-8.00/libpcreposix.la
/data/prj/pcre-8.00/libpcrecpp.pc.in
/data/prj/pcre-8.00/libpcre.pc.in
/data/prj/pcre-8.00/libpcreposix.pc.in
/data/prj/pcre-8.00/.libs/libpcre.exp
/data/prj/pcre-8.00/.libs/libpcre.so.0
/data/prj/pcre-8.00/.libs/libpcre.a
/data/prj/pcre-8.00/.libs/libpcre.lai
/data/prj/pcre-8.00/.libs/libpcre.la
/data/prj/pcre-8.00/.libs/libpcreposix.exp
/data/prj/pcre-8.00/.libs/libpcreposix.so.0
/data/prj/pcre-8.00/.libs/libpcreposix.a
/data/prj/pcre-8.00/.libs/libpcreposix.lai
/data/prj/pcre-8.00/.libs/libpcreposix.la
/data/prj/pcre-8.00/libpcre.pc
/data/prj/pcre-8.00/libpcreposix.pc
/data/prj/pcre-8.00/libpcrecpp.pc
/data/prj/pcre-8.00/libpcre.la



On Thu, Dec 10, 2009 at 1:49 PM, Bart van der Schans <
b.vanderschans@onehippo.com> wrote:

> On Wed, Dec 9, 2009 at 9:01 PM, Michael Felt <mamfelt@gmail.com> wrote:
> > I confess to being a bit lost in all of this. I am still stuck with the
> pcre
> > issue, even after adding:
> > --with-pcre=/data/prj/pcre-8.00 \
> >
> > checking for pcre-config... false
> > configure: error: Did not find pcre-config script at /data/prj/pcre-8.00
> >
> > michael@x054:[/data/prj/alpha/httpd-2.3.4-alpha]cd /data/prj/pcre-8.00
> > michael@x054:[/data/prj/pcre-8.00]find . -name pcre-config
> > ./pcre-config
> > michael@x054:[/data/prj/pcre-8.00]
> >
> > Suggestions? And I hope I am not just being blind...
>
> Doesn't configure check for -x "$with_pcre/bin/pcre-config"? Then you
> should have the pcre-config script in a bin sub folder.
>
> Bart
>

Mime
View raw message