httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Trawick <traw...@gmail.com>
Subject Re: svn commit: r883712 - /httpd/httpd/trunk/docs/manual/mod/core.xml
Date Tue, 24 Nov 2009 21:45:46 GMT
On Tue, Nov 24, 2009 at 3:00 PM, Jeff Trawick <trawick@gmail.com> wrote:
> On Tue, Nov 24, 2009 at 1:58 PM, William A. Rowe Jr.
> <wrowe@rowe-clan.net> wrote:
>> Jeff Trawick wrote:
>>>
>>> What about an optional third argument to Mutex to indicate that the
>>> pid should be omitted?
>>>
>>> Mutex default sysvsem
>>> Mutex ssl-cache file:/mnt/sesscachedir OmitPid
>>> etc.
>>
>> That seems sensible, but I'm left wondering how many different naming
>> conventions we can fit on one directive line.  Perhaps bOmitPID instead ;-)
>> This really becomes harder to follow than the existing multiple-syntaxes.
>>
>> Is there any reason not to name these mutexes in MixedCase?
>
> I like having the mutex type name as of the filename, and mixed case
> filenames are unexpected.  Beyond that, MixedCase and the "." before
> the pid suffix don't totally resolve readability.  Modules like
> mod_watchdog with multi-instance mutexes provide an instance string
> which gets inserted as "-" string prior to the . pid suffix.
>
> If the watchdog names are heartbeat and dialup (wild guess; I didn't
> look closely or try to configure the thing), the files would be
>
> logs/watchdog-callback-heartbeat.1359
> logs/watchdog-callback-dialup.1359
>
> (These are both instances of the "watchdog-callback" type, which is
> what would be specified on the Mutex directive.)
>
>> Is there any reason we can't invert the arg order, so that we have
>>
>> Mutex mutextype:name Resource [Resource ...] [OmitPid]
>
> Maybe it would be clearer if the optional OmitPid came before the list
> of mutexes?
>
>>
>> Of course, default could be assumed here.  So the above becomes
>>
>> Mutex SysVSem
>> Mutex file:/mnt/sesscachedir SSLSessionCache OmitPid
>>
>> (note the Resource tag can be the actual directive being mutexed, instead
>> of an alt-name).
>>
>> Thoughts?
>
> I'm fine with putting the mechanism:dir first followed by a list of
> mutex type names.  I'm not sure about where to put the OmitPid though.
>  I guess you get used to either after a while.
>
> (Joe suggested "Mutex name1,name2,name3 mechanism:dir"; I didn't get
> around to splitting up the first arg to implement that.)
>
>>> In the ssl-cache example, the name of the mutex will be simply
>>> /mnt/sesscachedir/ssl-cache
>>>

In case it wasn't clear, I'm very eager to clear up/re-implement/etc.
any remaining details of this lovely mess, but I'm hoping that more
minds will show up and then converge to something (anything) on the
more subjective aspects.

Mime
View raw message