httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gregg L. Smith" <li...@glewis.com>
Subject Re: Obsolete modules in 2.3
Date Tue, 17 Nov 2009 20:33:01 GMT
Lars Eilebrecht wrote:
> Or just use the 2.2 modules with 2.4.

It was just my recent findings with 2.3.3-alpha that this will not work.
If the APR 1.4(?) that was in httpd-2.3.3-alpha-deps.tar.gz is anything
close to what will be shipped with 2.4 then no, this may not work. I had
to rebuild all my 3rd party modules against this version to get them to run.

with mod_imagemap 2.2.14
------------------------------------------------------------------------
httpd: Syntax error on line 99 of /Apache23/conf/httpd.conf: Cannot load 
/Apache23/modules/mod_imagemap.so into server: The specified procedure 
could not be found.
------------------------------------------------------------------------

To me the easiest solution to gauge the use of these module is to simply
accidentally (on purpose) remove them from 2.2.15 and see how many
people complain. If no one does, it can then be deemed safe to remove, 
if you get flooded with complaints, then you will know maybe one or both
should not be. Personally, I use neither of them.

Just my thoughts,
Gregg




Mime
View raw message