httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rainer Jung <rainer.j...@kippdata.de>
Subject Re: svn commit: r835524 - in /httpd/mod_ftp/trunk: Makefile.apxs configure.apxs
Date Fri, 13 Nov 2009 11:37:52 GMT
On 13.11.2009 01:38, Jeff Trawick wrote:
> On Thu, Nov 12, 2009 at 6:52 PM, William A. Rowe Jr.
> <wrowe@rowe-clan.net> wrote:
>> trawick@apache.org wrote:
>>> Author: trawick
>>> Date: Thu Nov 12 20:14:51 2009
>>> New Revision: 835524
>>>
>>> URL: http://svn.apache.org/viewvc?rev=835524&view=rev
>>> Log:
>>> pick up r834900 and r834923 from mod_fcgid
>>>
>>> Follow up the awk compatibility fix in r834729 by selecting the most
>>> suitable awk, following the AC_PROG_AWK order (gawk, mawk, nawk, awk).
>>> As with AC_PROG_AWK, AWK=foo overrides.
>>>
>>> After r834729 a working conf was generated on Solaris when using
>>> /usr/bin/awk, but only by some fluke of command-line processing
>>> (-v was sort-of ignored; see PR for discussion).  Also, the LoadModule
>>> wasn't added in the right spot due to awk engine differences.
>>
>> Can't we take $AWK given in config_vars.mk/apr_rules.mk instead, using APXS?
> 
> As of this commit, yes.
> As of the next commit, which works around missing tolower() in nawk on
> some levels of Solaris by preferring /usr/xpg4/bin/awk, no.
> 
> I don't know levels of Solaris don't have tolower() in nawk.  Perhaps
> it isn't a practical concern.

Solaris 8 with man pages from 1999 has a working nawk tolower(). I tried
just now.

Furthermore the page

http://www.shelldorado.com/articles/awkcompat.html

contains nice tables stating that for 2.5 until 8 tolower() works for
nawk. So I'd say not a practical concern.

Regards,

Rainer

Mime
View raw message