httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul Querna <p...@querna.org>
Subject Re: [VOTE] release 2.3.3 as alpha
Date Thu, 12 Nov 2009 17:25:00 GMT
On Thu, Nov 12, 2009 at 3:22 AM, Graham Dumpleton
<graham.dumpleton@gmail.com> wrote:
> 2009/11/12 Graham Dumpleton <graham.dumpleton@gmail.com>:
>> FWIW, the @??@ symbols are coming from apu-1-config because they are
>> never expanded by configure script for apr-util. Ie., snippet from
>> apu-1-config is:
>>
>> LIBS="-lexpat -liconv"
>> INCLUDES=""
>> LDFLAGS=""
>> LDAP_LIBS=""
>> DBM_LIBS="@LDADD_dbm_db@ @LDADD_dbm_gdbm@ @LDADD_dbm_ndbm@"
>>
>> APRUTIL_LIBNAME="aprutil-${APRUTIL_MAJOR_VERSION}"
>>
>> APU_SOURCE_DIR="/Users/grahamd/Projects/apr-util-1.4-trunk"
>> APU_BUILD_DIR="/Users/grahamd/Projects/apr-util-1.4-trunk"
>> APR_XML_EXPAT_OLD="@APR_XML_EXPAT_OLD@"
>> APU_DB_VERSION="0"
>>
>> This has occurred because autoconf hadn't been run to regenerate
>> configure script last time I updated from subversion.
>>
>> Must of missed it. Remember to do it for apr. :-(
>>
>> Trying again now.
>
> Get past the problem with @??@ variables, but still get linking issues with:
>
> /usr/local/apr-1.4/build-1/libtool --silent --mode=link gcc -g -O2
>   -o ab  ab.lo
> /usr/local/apr-util-1.4/lib/libaprutil-1.la -lexpat -liconv
> /usr/local/apr-1.4/lib/libapr-1.la -lpthread
> Undefined symbols:
>  "_apr_pollset_create", referenced from:
>      _main in ab.o
>  "_apr_pollset_remove", referenced from:
>      _set_conn_state in ab.o
>  "_apr_pollset_poll", referenced from:
>      _main in ab.o
>  "_apr_pollset_add", referenced from:
>      _set_conn_state in ab.o
> ld: symbol(s) not found
> collect2: ld returned 1 exit status
>
> There are undefined references to them in libapr, but no actual code for it.
>

Maybe forgot to run buildconf & configure?

How those symbols are built changed in 1.4.x, but it still seems like
a build issue that they aren't getting linked in.

Anyways -- there is the httpd-2.3.3-alpha-deps tarballs -- those is
what I was referring to as bundled, and are the versions of
apr/apr-util i used when testing.

Mime
View raw message