httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Plüm, Rüdiger, VF-Group" <ruediger.pl...@vodafone.com>
Subject crash caused by SSL_free in ssl_filter_io_shutdown
Date Tue, 15 Sep 2009 09:15:45 GMT
I see a crash caused by SSL_free in ssl_filter_io_shutdown:

#0  0x0000002a96b42879 in kill () from /lib64/tls/libc.so.6
#1  <signal handler called>
#2  0x0000002a959dcc97 in ASN1_template_free () from /lib64/libcrypto.so.4
#3  0x0000002a959dcc11 in ASN1_primitive_free () from /lib64/libcrypto.so.4
#4  0x0000002a959dccf7 in ASN1_template_free () from /lib64/libcrypto.so.4
#5  0x0000002a959dcc11 in ASN1_primitive_free () from /lib64/libcrypto.so.4
#6  0x0000002a959dcd32 in ASN1_item_free () from /lib64/libcrypto.so.4
#7  0x0000002a95816592 in ssl_cert_free () from /lib64/libssl.so.4
#8  0x0000002a9581550a in SSL_free () from /lib64/libssl.so.4
#9  0x0000002a97fb74d2 in ssl_filter_io_shutdown (filter_ctx=0x552adcb890, c=0x552adcb040,
abortive=0) at /usr/src/debug/WAO-apache-2.2.13/httpd-2.2.13/modules/ssl/ssl_engine_io.c:987
#10 0x0000002a97fb849b in ssl_io_filter_output (f=0x552adcb8c0, bb=0x552add4518) at /usr/src/debug/WAO-apache-2.2.13/httpd-2.2.13/modules/ssl/ssl_engine_io.c:1449
#11 0x000000552aaeefaf in ap_lingering_close (c=0x552adcb040) at /usr/src/debug/WAO-apache-2.2.13/httpd-2.2.13/server/connection.c:84
#12 0x000000552aafb51e in worker_thread (thd=0x552ad1c230, dummy=Variable "dummy" is not available.
) at /usr/src/debug/WAO-apache-2.2.13/httpd-2.2.13/server/mpm/worker/worker.c:545
#13 0x0000002a96901137 in start_thread () from /lib64/tls/libpthread.so.0
#14 0x0000002a96bdd883 in clone () from /lib64/tls/libc.so.6

(gdb) bt full 
#0  0x0000002a96b42879 in kill () from /lib64/tls/libc.so.6
No symbol table info available.
#1  <signal handler called>
No symbol table info available.
#2  0x0000002a959dcc97 in ASN1_template_free () from /lib64/libcrypto.so.4
No symbol table info available.
#3  0x0000002a959dcc11 in ASN1_primitive_free () from /lib64/libcrypto.so.4
No symbol table info available.
#4  0x0000002a959dccf7 in ASN1_template_free () from /lib64/libcrypto.so.4
No symbol table info available.
#5  0x0000002a959dcc11 in ASN1_primitive_free () from /lib64/libcrypto.so.4
No symbol table info available.
#6  0x0000002a959dcd32 in ASN1_item_free () from /lib64/libcrypto.so.4
No symbol table info available.
#7  0x0000002a95816592 in ssl_cert_free () from /lib64/libssl.so.4
No symbol table info available.
#8  0x0000002a9581550a in SSL_free () from /lib64/libssl.so.4
No symbol table info available.
#9  0x0000002a97fb74d2 in ssl_filter_io_shutdown (filter_ctx=0x552adcb890, c=0x552adcb040,
abortive=0) at /usr/src/debug/WAO-apache-2.2.13/httpd-2.2.13/modules/ssl/ssl_engine_io.c:987
        ssl = (SSL *) 0x552adceda0
        type = 0x2a97fc84ac "unclean"
        sslconn = (SSLConnRec *) 0x552adcb778
        shutdown_type = Variable "shutdown_type" is not available.

Not sure if httpd is the culprit or openssl (openssl 0.9.7a RHEL4).
Has somebody seen this before?

Regards

Rüdiger

Mime
View raw message