httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ruediger Pluem <rpl...@apache.org>
Subject Re: svn commit: r819008 - in /httpd/httpd/trunk: build/get-version.sh build/rpm/httpd.spec.in buildconf
Date Fri, 25 Sep 2009 22:01:02 GMT


On 09/25/2009 11:02 PM, minfrin@apache.org wrote:
> Author: minfrin
> Date: Fri Sep 25 21:02:33 2009
> New Revision: 819008
> 
> URL: http://svn.apache.org/viewvc?rev=819008&view=rev
> Log:
> Add support for an "epoch" in the RPM spec file. This epoch is a discrete
> number used to determine if one RPM is newer than another, which in turn
> ensures that v1.2.10 is always interpreted as newer than v1.2.9.
> 
> Modified:
>     httpd/httpd/trunk/build/get-version.sh
>     httpd/httpd/trunk/build/rpm/httpd.spec.in
>     httpd/httpd/trunk/buildconf
> 

> Modified: httpd/httpd/trunk/build/rpm/httpd.spec.in
> URL: http://svn.apache.org/viewvc/httpd/httpd/trunk/build/rpm/httpd.spec.in?rev=819008&r1=819007&r2=819008&view=diff
> ==============================================================================
> --- httpd/httpd/trunk/build/rpm/httpd.spec.in (original)
> +++ httpd/httpd/trunk/build/rpm/httpd.spec.in Fri Sep 25 21:02:33 2009
> @@ -7,13 +7,14 @@
>  Name: httpd
>  Version: APACHE_VERSION
>  Release: APACHE_RELEASE
> +Epoch: APACHE_EPOCH00%{release}

Why APACHE_EPOCH00%{release} and not just APACHE_EPOCH?

>  URL: http://httpd.apache.org/
>  Vendor: Apache Software Foundation
>  Source0: http://www.apache.org/dist/httpd/httpd-%{version}.tar.bz2
>  License: Apache License, Version 2.0
>  Group: System Environment/Daemons
>  BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
> -BuildPrereq: apr-devel, apr-util-devel, openldap-devel, db4-devel, expat-devel, findutils,
perl, pkgconfig, zlib-devel, pcre-devel >= 5.0
> +BuildPrereq: apr-devel, apr-util-devel, openldap-devel, db4-devel, expat-devel, findutils,
perl, pkgconfig, zlib-devel, pcre-devel >= 5.0, distcache-devel >= 1.4

Was this change intended?

>  BuildPrereq: /usr/bin/apr-1-config, /usr/bin/apu-1-config
>  Requires: apr >= 1.4.0, apr-util >= 1.4.0, pcre-devel >= 5.0, gawk, /usr/share/magic.mime,
/usr/bin/find, openldap
>  Prereq: /sbin/chkconfig, /bin/mktemp, /bin/rm, /bin/mv

Regards

RĂ¼diger

Mime
View raw message