httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rainer Jung <>
Subject Re: [mod_fcgid] Cleaning up configuration directive names
Date Mon, 21 Sep 2009 18:07:53 GMT
On 21.09.2009 18:51, Chris Darroch wrote:
> Rainer Jung wrote:
>> The names of the configuration directives of mod_fcgid are somehow
>> inconsistent. At least it's abit hard to remmber, that some directives
>> use a prefix FCGI, others use FastCgi (and most do not have a prefix for
>> a namespace).
>> I'm not sure, how important we take configuration compatibility with the
>> pre-existing mod_fcgid (non-ASF) but I think we should at least cleanup
>> th einconsistent use of FCGI vs. FastCgi.
>> Comments?
>   A year or two ago I worked up this patch against what was then
> the CVS HEAD of mod_fcgid, because I found the variation of directive
> names too confusing when trying to figure out what to tune in a
> running config:
>   I'm sure there's lot to further adjust here, not to mention
> the fact that the patch doubtless won't apply cleanly anymore.
> I also have come to prefer FCGI as the prefix, to distinguish the
> module from mod_fastcgi.
>   However, I'd throw it in as a set of initial suggestions for
> the renamed directives, at least.  I recall making an effort to
> align the names to other httpd directives, as well as to each
> other, so that closely related directives grouped together by
> name.  I also worked over the brief descriptions of what each
> directive does to try to make them more clear.
>   So (using the FCGI prefix) we have various parallels to httpd
> directives, such as FCGIMaxRequestsPerServer, FCGILimitRequestBody,
> FCGITimeout, etc.
>   Directives relating to the maximum and high-water-mark numbers
> of FastCGI processes are treated akin to similar directives for
> mod_dbd: FCGIMaxServersPerScript, FCGIKeepServersPerScript.
>   Then there are lots of parallels within related sets of
> directives: FCGIIdleTimeout, FCGIIdleScanInterval, FCGIBusyTimeout,
> FCGIBusyScanInterval, FCGIErrorScanInterval, FCGIExitScanInterval,
> etc.
>   I remember one hard part was trying to deal with the directive
> names relating to the "spawn" and "terminate" scores.  I don't
> think what I came up with (FCGIServerExitValue, etc.) are very good,
> on reflection.  It's very possible that "spawn score" is in fact
> perfectly adaquate as a description.
>   Anyway, once some travel is done with this week, I hope to
> get cracking on gradually refactoring these old patches of mine.
> In the meantime, if others want to grab what they like and
> dump the rest, please do so.

I read your mail to late, but maybe that's not really a problem. I
switched all names from XXX to FCGIDXXX except for FCGIWrapper, which is
now FCGIDWrapper and PHP_Fix_Pathinfo_Enable is FCGIDPHPFixPathinfoEnable.

I also added a table and some notes to the changes and the docs as well
as a simple sed script (not very ingenious).

I don't want you stop thinking about better names and I think most of
the changes, like having a table in the docs and upgrade notes apply anyhow.

Once we come up with better names and/or descriptions, I'll help in
fixing mod_fcgid.c, README, CHANGES, manual and sed script.



View raw message