httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "William A. Rowe, Jr." <wr...@rowe-clan.net>
Subject Re: svn commit: r795451 - /httpd/httpd/branches/2.2.x/STATUS
Date Wed, 02 Sep 2009 02:12:27 GMT
Nick Kew wrote:
> William A. Rowe, Jr. wrote:
>> Nick...
>>
>> should we discuss an alternate name?  Or should I simply revert the patch
>> vetoed on trunk?
> 
> I'm easy on the name.
> 
> Let's ping DrBacchus - this was his feature request :-)
> 
>> Can we compromise on the name NotFoundHandler, MissingFileHandler,
>> NotFoundAction,  MissingFileAction, or any of a dozen other possible
>> variations that don't contain the misleading word "Default"?
> 
> FWIW, I preferred your earlier suggestion of Fallback[Handler|Action].

If this mirrors the behavior of Action (in the way variables are presented
to the fallback resource) then FallbackAction makes the most sense.

If it is restricted to a filespec at the same dir level, then perhaps
FallbackFilename makes the most sense.  (If it can be at the same level
or in another path, FallbackFile or FallbackResource might be better).

Rich?  Pipe up - you know we programmers are useless for naming things.
You make short, sweet and to the point choices.  E.g., ponies.




Mime
View raw message