httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rainer Jung <rainer.j...@kippdata.de>
Subject Sporadically broken Download for 2.2.13 windows binaries
Date Tue, 25 Aug 2009 15:19:07 GMT
Hi,

I observed strange behaviour for the Windows 2.2.13 binary download.

Retrieving it with Firefox and with MSIE 8 directly from

http://archive.apache.org/dist/httpd/binaries/win32/apache_2.2.13-win32-x86-openssl-0.9.8k.msi

stopped downloading after 4.923.392 Bytes instead of 6.034.944 Bytes.
Both browsers stopped after exactly the same size. The resulting file
was obviously corrupt.

Downloading with wget did the job. I could reproduce the problem twice
with Firefox, but the third time it worked and retrieved the full file.

No error message from the browsers, but yet another test using curl reveals:

curl: (18) transfer closed with 1111552 bytes remaining to read

So I tried again with curl, now instead of using Windows on Solaris and
a different curl version. Same problem, same point where the file stops
to download.

HTTP Headers seem to be fine, version of httpd on the server is 2.2.12,
IP adress used for archive.a.o was 140.211.11.130.

So it seems the archive server, file, config or combination of it all is
broken.

Can anyone confirm the problem, so I might inform infra?

Regards,

Rainer

Mime
View raw message