httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "William A. Rowe, Jr." <wr...@rowe-clan.net>
Subject Re: Segfault with fix for CVE-2009-1891
Date Tue, 28 Jul 2009 23:08:52 GMT
Akins, Brian wrote:
> On 7/28/09 1:35 PM, "Stefan Fritsch" <sf@sfritsch.de> wrote:
> 
>> I have backported r791454 to 2.2.3 in Debian 4.0 and have received a
>> report [1] about segfaults with mod_deflate and mod_php (5.2.0).
> 
> Isn't php only officially supported via fastcgi?

Last I read, the PHP license has no warranty.

One helpful detail, Stefan, would be if this is worker-specific or can
be reproduced with prefork.  That helps narrow down the number of places
to consider your question.

As I recall, we have several filter bug fixes in deflate over the past
years, so it's not a really surprising result.



Mime
View raw message