httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Guenter Knauf <fua...@apache.org>
Subject Re: Including apu_version.h and APR 2.0
Date Sat, 11 Jul 2009 16:53:14 GMT
Hi,
Guenter Knauf schrieb:
> I would prefer to stay with the '#ifdef APR_VERSION < 2' because they
> cost us nothing, and at least at the moment it is possible to build
> httpd-2.2.x with APR 2.0.0-dev - just tested with NetWare, and
> absolutely no prob, compiles and runs.
Surprisingly I've just found that we still have apu_version.h +
apu_version() with APR-2.0.0-dev, and if we keep this in future then I
even see no reason to ifdef mod_info in trunk ....

Bill, do we keep apu_version.h with APR-2.x, or will it be removed?
Maybe we can just:
#define APU_VERSION APR_VERSION
#define apu_version apr_version

and have then a simple backward compat?

Gün.



Mime
View raw message