httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Takashi Sato <>
Subject Including apu_version.h and APR 2.0
Date Thu, 09 Jul 2009 13:53:52 GMT
mod_info's new feature doesn't compile against apr/apr-util 1.3.x

/usr/home/test/httpd-trunk/modules/generators/mod_info.c: In function 'show_server_settings':
/usr/home/test/httpd-trunk/modules/generators/mod_info.c:363: warning: implicit declaration
of function 'apu_version_string'
/usr/home/test/httpd-trunk/modules/generators/mod_info.c:363: warning: format '%s' expects
type 'char *', but argument 3 has type 'int'
/usr/home/test/httpd-trunk/modules/generators/mod_info.c:366: error: 'APU_VERSION_STRING'
undeclared (first use in this function)
/usr/home/test/httpd-trunk/modules/generators/mod_info.c:366: error: (Each undeclared identifier
is reported only once
/usr/home/test/httpd-trunk/modules/generators/mod_info.c:366: error: for each function it
appears in.)

Include apu_version.h and this is fixed, but considering APR 2.0.....
apu_version.h does exist in APR 2.0, so we don't need to care APR version?
Or we should enclose it with #if APR_MAJOR_VERSION < 2 ?

View raw message