httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Trawick <traw...@gmail.com>
Subject [PATCH] "fix" recognition of APR 2.x
Date Mon, 02 Mar 2009 14:38:52 GMT
Check out trunk.  Check out APR trunk and APR-Util trunk into srclib/apr and
srclib/apr-util.  "./configure --with-included-apr".  See error messages
containing "apr-1-config" scroll by.

trunk/configure.in looks for apr-2-config, but it does so before srclib/apr
is configured, when apr-2-config doesn't exist (unless the user configures
srclib/apr first).

The attached patch checks the version after the configure.  It also attempts
to handle the APR_FIND_APR() path (untested).  On the APR-Util side, it
bases the apu-config path on the APR major version and tells APR_FIND_APU()
to find one that matches APR's major version (latter part untested).

I wouldn't be at all surprised if other folks are already using APR trunk
with httpd trunk daily and I've missed something basic, so comments
appreciated ;)

Mime
View raw message