httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Perry Smith <>
Subject Syntax error in configure script
Date Fri, 23 Jan 2009 15:39:04 GMT
I was not sure which list to try first: development or bug.  This may  
turn out to be a bash bug but I thought I would start here.

I'm trying to run the configure script for httpd.  It calls the  
configure script for srclib/apr-util.
I'm running AIX 5.3.  I have tried bash 3.2 with patches as of  
December of 2008.  I just tried again with bash-3.2.48.  I also have  
gawk installed but I do not have GNU's sed (I mention that because GCC  
seems to require both)

The apr-util configure script is being called:

   $ /usr/local/src/httpd-2.2.11/srclib/apr-util/configure --disable- 
option-checking --enable-mods-shared=most --enable-ssl --with-ldap -- 
enable-authnz-ldap --enable-ldap --with-ssl=/usr/local/ssl --enable- 
proxy=shared --with-dbm=db47 --with-berkeley-db=/usr/local/BerkeleyDB. 
4.7 --cache-file=/dev/null --srcdir=/usr/local/src/httpd-2.2.11/srclib/ 
apr-util --with-apr=../apr --prefix=/usr/local/apache2 --exec-prefix=/ 
usr/local/apache2 --libdir=${prefix}/lib --includedir=/usr/local/ 
apache2/include --bindir=${prefix}/bin

The syntax error I get is:

checking style of ldap_set_rebind_proc routine... three
/usr/local/src/httpd-2.2.11/srclib/apr-util/configure: line 19709:  
syntax error near unexpected token `|'
/usr/local/src/httpd-2.2.11/srclib/apr-util/configure: line 19709: `  * 
\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;'
configure failed for srclib/apr-util

I have tried an in-tree build as well as an out of tree build.

The reason I think that it may be a bash error is AIX's native ksh can  
run the script clean.  I'm happy to help out debugging this but I  
never understood the autogen stuff very much.

Ease Software, Inc. ( )

Low cost SATA Disk Systems for IBMs p5, pSeries, and RS/6000 AIX systems

View raw message