httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ruediger Pluem <rpl...@apache.org>
Subject Re: Palm Treo access to OWA via Apache 2.2.x Proxy
Date Thu, 22 May 2008 08:32:25 GMT


On 05/22/2008 03:05 AM, Ray Van Dolson wrote:
> I'm having a heck of a time getting Palm Treo's to work through our
> Apache 2.2.3 based proxy talking to an OWA2K7 setup running on IIS.  I
> believe I may be getting pinched by:
> 
>   https://issues.apache.org/bugzilla/show_bug.cgi?id=43238
> 
> The Treo seems to work fine without a proxy.  I observe the following
> (no proxy):
> 
>    1 TREO   Sends OPTIONS request to IIS (Connection: Keep-Alive)
>    2 IIS    Replies with 200 OK (No Connection header)
>    3 TREO   Sends POST /Microsoft-Server-ActiveSync... (Connection: Keep-Alive)
>    4 IIS    Replies with 200 OK + payload (No Connection header)
> 
> As I said, everything works fine this way.  With mod_proxy in the mix
> however:
> 
>    1 TREO   Sends OPTIONS request to Apache (Connection: Keep-Alive)
>    2 Apache Sends OPTIONS request to IIS (Connection: Close)
>    3 IIS    Replies with 200 OK (Connection: Close)
>    4 Apache Sends 200 OK back to Treo (Connection: Close)
>    5 Apache Sends SSLv3 Close Notify to Treo
>    6 Apache Sends FIN,ACK to Treo
>    7 TREO   Sends POST /Microsoft-Server-ActiveSync... (Connection: Keep-Alive)
>    8 Apache Sends ACK to Treo
>    9 Apache Sends Dup ACK to Treo
>   10 Apache Sends Dup ACK to Treo
> 
> Timeout...

First, please try using Apache 2.2.8 plus patches. There have been numerous changes to
the proxy code between 2.2.8 and 2.2.3.
Second, is the above behaviour with or without the patch from PR43238?
Third, please post your proxy configuration.

Regards

RĂ¼diger

Mime
View raw message