httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ray Van Dolson <rvandol...@esri.com>
Subject Re: Palm Treo access to OWA via Apache 2.2.x Proxy
Date Thu, 22 May 2008 20:23:23 GMT
On Thu, May 22, 2008 at 08:53:41AM -0700, Ray Van Dolson wrote:
> On Thu, May 22, 2008 at 01:32:25AM -0700, Ruediger Pluem wrote:
> >
> >
> > On 05/22/2008 03:05 AM, Ray Van Dolson wrote:
> > > I'm having a heck of a time getting Palm Treo's to work through our
> > > Apache 2.2.3 based proxy talking to an OWA2K7 setup running on IIS.  I
> > > believe I may be getting pinched by:
> > >
> > >   https://issues.apache.org/bugzilla/show_bug.cgi?id=43238
> > >
> > > The Treo seems to work fine without a proxy.  I observe the following
> > > (no proxy):
> > >
> > >    1 TREO   Sends OPTIONS request to IIS (Connection: Keep-Alive)
> > >    2 IIS    Replies with 200 OK (No Connection header)
> > >    3 TREO   Sends POST /Microsoft-Server-ActiveSync... (Connection: Keep-Alive)
> > >    4 IIS    Replies with 200 OK + payload (No Connection header)
> > >
> > > As I said, everything works fine this way.  With mod_proxy in the mix
> > > however:
> > >
> > >    1 TREO   Sends OPTIONS request to Apache (Connection: Keep-Alive)
> > >    2 Apache Sends OPTIONS request to IIS (Connection: Close)
> > >    3 IIS    Replies with 200 OK (Connection: Close)
> > >    4 Apache Sends 200 OK back to Treo (Connection: Close)
> > >    5 Apache Sends SSLv3 Close Notify to Treo
> > >    6 Apache Sends FIN,ACK to Treo
> > >    7 TREO   Sends POST /Microsoft-Server-ActiveSync... (Connection: Keep-Alive)
> > >    8 Apache Sends ACK to Treo
> > >    9 Apache Sends Dup ACK to Treo
> > >   10 Apache Sends Dup ACK to Treo
> > >
> > > Timeout...
> >
> > First, please try using Apache 2.2.8 plus patches. There have been
> > numerous changes to the proxy code between 2.2.8 and 2.2.3.
> 
> I figured as much and will do that today.

I'm running the latest svn version from the 2.2.x branch (659141 when I
compiled).  The Treo still doesn't work.  I see similar behavior to
that of the above.  I could open a bz bug for this and include tcpdumps
(can the bugs be tagged private?)

Note that my compile is against the RHEL5 version of apr and apr-util
(1.2.7 I believe).  Would this impact anything?

I still wonder why Apache is sending the Connection: Close header in #2
above.  IIS doesn't do this (and the Treo works direct there).

Appreciate any insight.
Ray

Mime
View raw message