httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Randy Kobes <ra...@theoryx5.uwinnipeg.ca>
Subject Re: apxs on Win32?
Date Tue, 04 Mar 2008 03:09:14 GMT
On Thu, 21 Feb 2008, William A. Rowe, Jr. wrote:

> Guenter Knauf wrote:
>> Hi (Bill?),
>> another dev just asked me privately about apxs for Win32....
>> does this meanwhile work on Win32?
>> And if so can we perhaps ship it with future distros?
>> I think that would make sense since the include and lib dir is already 
>> included....
>
> Dunno if Randy's package has been updated for trunk, 2.2 etc, but
> it's been mentioned several times that this should be incorporated
> back into httpd.  (It was dropped with 2.0, after I solved it for 1.3,
> given the additional complexity behind the autocrap/libfool stuff we
> introduced into httpd 2.0).
>
> So maybe it's time to get cracking ;-)
>
> Bill

The apxs win32 package does work for 2.2. I'm not sure the
best way to incorporate this into the httpd build; as a
first step, I've placed at
    http://people.apache.org/~randyk/
an install_win32_apxs.zip which can be used as
    nmake -f install_win32_apxs.mak INSTDIR=C:\Path\to\Apache2.x
to install apxs, apr-config, and apu-config. This assumes
a point in the installation when Apache has been installed
(eg, towards the end of httpd's Makefile.win). Compared to
the apxs utility at
    http://perl.apache.org/dist/win32-bin/
this version is more minimalistic (no user prompts, etc.);
the modules used are included with modern versions of
Perl.

One thing it does assume is that Perl is in the PATH; I'm
not sure how to check for this in the Makefile.

-- 
best regards,
Randy

Mime
View raw message