httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dirk-Willem van Gulik <di...@webweaving.org>
Subject Re: Caching the useful headers
Date Fri, 08 Feb 2008 23:00:46 GMT

On Feb 8, 2008, at 11:56 PM, Ruediger Pluem wrote:

> There is a slightly different usage of ap_cache_cacheable_hdrs_out in
> mod_cache itself. So I would prefer:

Below makes sese -- but is the use in mod_cache correct ?

> 1. Rename ap_cache_cacheable_hdrs_out to ap_cache_cacheable_hdrs and  
> keep it public.
> 2. Create ap_cache_cacheable_hdrs_out / ap_cache_cacheable_hdrs_in  
> as proposed by you
>   and add them to the API.
>
> I think we can only do this change on trunk as it would require a  
> major bump.
> Ok, formally mod_cache.h is not public, but I agree with your  
> proposal that it *should*
> be public and so we should not rename ap_cache_cacheable_hdrs_out to  
> ap_cache_cacheable_hdrs
> without a major bump IMHO.

Or we keep the old slightly odd names.

Dw

Mime
View raw message