httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John ORourke <john-p...@o-rourke.org>
Subject flood reg ex matching problems
Date Thu, 21 Feb 2008 09:44:26 GMT
Hi folks,

I grabbed flood from svn and built it according to the instructions at 
http://httpd.apache.org/test/flood/

I've been getting 'Regular expression match failed' most of the time, 
and even tried running one of the examples:

----------------------
root@bella:/home/staff/john/flood# /usr/local/flood/bin/flood 
examples/round-robin-dynamic.xml
Regular expression match failed (<a href="([^"]*)">FAQ</a>)
postprocessing failed (http://httpd.apache.org/).
Error running farmer 'Joe': Internal error.
----------------------

I even tried a ridiculously simple one and it still failed:
    <url responsetemplate="(DOCTYPE)" 
responsename="foo">http://httpd.apache.org</url>

I've even tried updating my pcre version (v3 was installed on this 
Ubuntu system) to no avail - it looks as though theres a version 
compiled in statically anyway (I'm using --disable-shared as per the 
doc, not sure if it has any effect on pcre).

I've had some simple regex's working - eg. if I try 
responsetemplate="href=&quot;([^&quot;]+)&quot;" it sometimes works.

Any ideas?

thanks in advance,
John O'Rourke


Mime
View raw message