httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Roy T. Fielding" <field...@gbiv.com>
Subject Re: AP_CONN_CLOSE on force-response-1.0
Date Fri, 12 Oct 2007 22:21:17 GMT
On Oct 12, 2007, at 12:25 AM, Aleksey Midenkov wrote:

> On Thursday 11 October 2007 21:57:21 Roy T. Fielding wrote:
>> On Oct 11, 2007, at 12:55 AM, Aleksey Midenkov wrote:
>>>> This is all irrelevant.  No current installation should need any of
>>>> those env variables set.  They exist solely for working around old
>>>> versions of old clients that no longer exist on the net.
>>>
>>> Not all... We need mod_proxy responding exactly with what protocol
>>> backend
>>> server sent. For this purpose we use force-response-1.0.
>>
>> Then you are violating the HTTP standard.
>>
>> ....Roy
>
> Why?

RFC 2616, sec 3.1:

    Due to interoperability problems with HTTP/1.0 proxies discovered
    since the publication of RFC 2068[33], caching proxies MUST,  
gateways
    MAY, and tunnels MUST NOT upgrade the request to the highest version
    they support. The proxy/gateway's response to that request MUST  
be in
    the same major version as the request.

....Roy

Mime
View raw message